1

I don't have a monitor just at the hand, but I want to use my Raspberry Pi with Ubuntu Mate... How do I activate the SSH on it? When trying to ssh to it, it says 'Connection refused'

  • 1
    IIRC it already is enabled the change only affected Raspbian. Have you tried connecting to it? – Steve Robillard May 15 '17 at 18:01
  • @SteveRobillard But it gives me 'Connection Refused' when trying... – Taumen May 15 '17 at 18:02
  • You can try adding an ssh file (no extension) to the boot directory and rebooting, but I suspect that it is either not installed or not started. – Steve Robillard May 15 '17 at 18:04
  • @SteveRobillard Yeah, I have tried that as well... – Taumen May 15 '17 at 18:06
  • 1
    If you must do this headless you may be better off using Raspbian. – Steve Robillard May 15 '17 at 18:37
0

Unluckily you have to do first configuration with the hdmi and enable the ssh service. This because a recent patch that disabled ssh on first boot. Regards, sorry for my bad english

| improve this answer | |
0

After you attach a monitor to your Pi3, open up a terminal and enter in

sudo systemctl enable sshd
sudo systemctl start sshd

I recommend installing ufw on any Pi device

sudo apt install ufw

Now to allow ssh connections:

sudo ufw allow ssh
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.