2

I have a Raspberry Pi 3 setup running raspbien (usual os, jesie). I use mobaxterm to connect to the box and start up a gui. I can run several apps fine..such as gimp for instance. When I try and launch chromium_browser, the screen does not display. After digging I find mention that there is an incompatibility with the most recent version of libpng and the latest version of chrome. I might have even seen something about sym linking an older version of the libray and recompiling (or perhaps its just shared).

I see an error /usr/lib/chromium-browser/nacl_helper: Cannot open ELF file! errno=2 that mentions nacl and something about protocol. Whats going on here?

I do not even have a file called usr/lib/chromium-browser/nacl_helper

should I?

Any help with a solution that gets this thing running would be much appreciated. I used to be a programmer many years ago and did not want to dig into code and/or recompile. I used to dev for windows and look at my new venture into rasp pi/open source as the wild wild west.

I wondered if my x windows was set up ok... ssh, echo display variable (:0) . since other apps work, i think it is something in the latest chromium, the error is very archic. PLease help. Thanks.

  • Please add the exact, correct error message. – Thorbjørn Ravn Andersen Sep 8 '17 at 6:52
  • All the info I have is above. The error message is "Cannot open ELF file! errno=2" It wasn't a graceful error that had more thought going into it. It was more like the program was starting up and all of a sudden just stopped in its tracks with the message above, I had even tried to start it from a command prompt, looked like it wa sdoing something for a while, then the message above and back to the command prompt. – Jeffrey Edward Messikian Sep 10 '17 at 14:14
  • errno=2 means missing file. Can you use another browser? – Thorbjørn Ravn Andersen Sep 10 '17 at 15:45
  • Yes, the other browser on the install worked fine. I preferred to run Chrome. I have not had time to revisit the problem since this post and my earlier research. It might be fixed now in an updated release of Chrome, the OS, or shared libraries installed. – Jeffrey Edward Messikian Sep 11 '17 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.