4

I'm trying to change the password on my RPi 3. I've tried sudo passwd and it gets me to the screen where I can enter a new password, but then the terminal stops letting me type. Does anyone know how to work around this? I've also tried sudo raspi-config but that still doesn't do anything

7

Linux doesn't display anything when you type your password. no asterisks, no dots, no nothing.

After entering passwd on the command line and pressing enter type your password at the command prompt, nothing will display but that's ok.

Raspberry pi document say:

Enter passwd on the command line and press Enter. You'll be prompted to enter your current password to authenticate, and then asked for a new password. Press Enter on completion and you'll be asked to confirm it. Note that no characters will be displayed while entering your password. Once you've correctly confirmed your password, you'll be shown a success message (passwd: password updated successfully), and the new password will apply immediately.

  • I'm really sorry, I didn't realize that Linux doesn't show your password when you type it. – user67265 May 17 '17 at 3:39
4

Do NOT type sudo passwd (unless you are trying to change the password of another user).

The command to change your password is passwd

  • If you do not remember the password and are trying to ssh into the pi, sometimes you need to use sudo passwd pi, to force changing the password without authenticating before hand with a password you do not know. – Joe Sep 6 '18 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.