1

I have a Raspbian Jessie installation where mmcblkp01 is not mounted. During boot I see this message on the console:

 start job running for `dev-mmcblk0p1.device`

Eventually this times out and I am dropped into the emergency mode. When I enter the root password I can mount mmcblk0p1.device without a problem:

 mount /dev/mmcblk0p1 /boot

The line in /etc/fstab is:

 /dev/mmcblk0p1  /boot  vfat  defaults  0  2

The mmcblk0p1 is a normal VFAT partition. The start and end sectors are equal to a working Raspbian installation.

If it is relevant, sysctl cannot start dev-ttyAMA0 either.

Now I can take the easy way and make a fresh install, but I want to understand why this happens. So the main question is, where can I start to search why mmcblk0p1 is not mounted? Or why the dev-mmcblk0p1.device service is not started.

How I ended up here:

Some background information. Raspbian did not start to refuse mounting mmcblk0p1 all by itself. This is the history:

  1. I had a working Raspbian Wheezy installation
  2. Dist-upgraded that to Jessie (still no problem)
  3. Mounted a USB external hard disk as root file system
  4. Changed cmdline.txt to use the USB disk as root file system
  5. Changed /etc/fstab to mount the USB disk on '/' instead of mmcblk0p2

I did not touch anything related to mmcblk0p1 or the boot partition or whatever. When mounting a different device as a root file system there must always be a boot partition on the SD card. That is how the Pi works.

This installation worked all fine. I need the HDD because I am running a data logger on a MySQL database and I don't want to wear out the SD card.

Next, I made a full rsync copy of the installation.

The Pi with USB HDD went into production

But I need a shadow system to continue testing and development

This time without external HDD because the Pi is not running continuously. The development Pi had a Wheezy install.

I took out the SD card from the Pi and mounted it on my desktop machine.

sdc2 -> /mnt/pi-root

sdc1 -> /mnt/pi-root/boot

Rsync-ed the previously made image to the SD card. Modified cmdline.txt and /etc/fstab to the normal original versions as for using the SD card as root FS.

Placed the SD card back in the Pi and then the problem occurred.

I just want to understand why mmcblk0p1 is not mounted. I am sure I can solve the problem to get a working system back. But for future projects I want to know how I can clone a production system back into a development system.

  • The Foundation NEVER provided a dist-upgrade from Wheezy to Jessie so you presumably used one of the unsupported kludges. Who knows what you have? Just do a clean installation. – Milliways May 18 '17 at 0:00
  • I did not complain, just tried to understand. The once executed dist-upgrade went fine as far as I could see. The really stupid thing I did was to copy the Jessie image back to an existing Wheezy SD. Once I created a pristine Jessie minimal SD, copied back my production image and everything was fine. Which is, in fact, amazing as well. – Hans Linkels May 18 '17 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.