2

I'm attempting to get streaming video working.

One of the answers here: RasPi Camera Board and Motion suggested using the command sudo modprobe bcm2835-v4l2.

First I ran:

sudo apt-get update
sudo apt-get dist-upgrade
sudo modprobe bcm2835-v4l2

However, when I run this command on my RPi 3 Model B I get the following:

modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() 
could not open moddep file '/lib/modules/4.4.50-v7+/modules.dep.bin'
3

So I had the same issue. I found here that the linux image should be reinstalled ( #apt-get install --reinstall linux-image-$(uname -r)).

However, at the time this answer is written, the only images on the raspbian repo are 4.4.0, while uname -r returned 4.4.5 on my raspbian. Meanwhile, ls /lib/modules/ contained 4.9.x dirs.

So I don't know what happened to the raspbian image, but installing rpi-update and then running it fixed the issue for me:

sudo apt-get install rpi-update && sudo rpi-update

If you need a specific kernel version, well, you gotta install it yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.