0

I bought a Wi-Fi adapter to use on my Pi 2. I've already installed the driver rtl8192eu, (found on github). but, when I run lsusb, the Pi cant recognize the Wi-Fi adapter, it just shows me:

Bus 001 Device 005: ID 2357:0109

when I run lsmod, I get this:

Module                  Size  Used by
bnep                   10340  2 
bluetooth             326105  5 bnep
binfmt_misc             6388  1 
cfg80211              428871  0 
rfkill                 16037  4 cfg80211,bluetooth
8192eu                908687  0 
joydev                  9024  0 
evdev                  11396  6 
snd_bcm2835            20447  1 
snd_pcm                75762  1 snd_bcm2835
snd_timer              19288  1 snd_pcm
snd                    51908  5 snd_bcm2835,snd_timer,snd_pcm
bcm2835_wdt             3225  0 
bcm2835_gpiomem         2976  0 
uio_pdrv_genirq         3164  0 
uio                     8000  1 uio_pdrv_genirq
i2c_dev                 5859  0 
fuse                   84037  3 
ipv6                  347620  72 

when I run iwconfig, I get this:

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

I'm using kernel version 4.4.50-v7+ and I would prefer not to upgrade it for a newer version.

can anyone explain what is happening and how to solve this?

0

1 Answer 1

0

when i do lsusb, rpi cant recognize the wifi adapter

Bus 001 Device 005: ID 2357:0109

That output is fine. That's how the device identifies itself. I believe the string often shown (e.g., Acme 0.1 wifi adapter) is one the kernel gets from somewhere, but not necessarily an actual driver because it will identify devices with no driver too. Perhaps it comes from the device -- in any case it is not important.

when i do iwconfig, i get this

wlan0 unassociated Nickname:"<WIFI@REALTEK>"

If the driver works well enough for that, most likely it will work in general. If the driver did not work, the interface would not be listed at all.

can anyone explain what is happening and how to solve this?

None of this amounts to a problem.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.