3

I ran sudo apt-get install npm in the terminal:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
           Recommends: fonts-liberation but it is not going to be installed or
                       ttf-mscorefonts-installer but it is not going to be installed
 libreoffice-base : Depends: libreoffice-base-core (= 1:4.3.3-2+rpi3) but 1:4.3.3-2+rpi4 is to be installed
 libreoffice-base-core : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 libreoffice-calc : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 libreoffice-draw : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 libreoffice-gtk : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
               Recommends: libreoffice-style-tango but it is not going to be installed
 libreoffice-impress : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 libreoffice-math : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 libreoffice-writer : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
 npm : Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
 python3-uno : Depends: libreoffice-core (= 1:4.3.3-2+rpi4) but 1:4.3.3-2+rpi3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then I typed npm -v which resulted in:

bash: npm: command not found

What should I do? so that last line error could be solved?

  • 3
    Did you try what it tells you to try in the last line?? – goldilocks May 19 '17 at 13:16
8

Don't install Node.js directly from apt—it's hideously out of date, and most of the features you're expecting to have won't work. The version in the repositories at the minute is v0.10.29, while the current release as of writing is v7.10.0.

Instead, follow the advice given to install Node (and npm) from their website:

curl -sL https://deb.nodesource.com/setup_7.x | sudo -E bash -
sudo apt-get install -y nodejs

Note that this will only work for Pis with an ARMv7 (or greater) processor—the Pi Zero and the original Model B won't cut it, as noted here.

After completing the installation, both Node.js and npm will be installed using the latest (or a very recent) version.

1

Your install command obviously failed (surely you read the output!?). Why would you be able to run npm -v?

  1. Run apt-get -f install npm to fix the installation issue.
  2. Run npm -v

That should solve your issue.

  • I wouldn't recommend installing Node and npm from the Debian repositories directly. They're really out of date—so much so that most Node libraries and programs won't work at all. Using apt-get like this will get npm installed, but it's probably not going to be the version that is expected, and might not work at all (the error looks like maybe Node wasn't installed through apt, so it might be a more recent version or something... hard to tell) – Aurora0001 May 19 '17 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.