8

I use my Raspberry Pi with Kodi on it (probably one of the last version with both a Pi 2 and 3).

A few months ago, I bought and HDMI extractor so that I could use my Home Cinema using the Passthrough option in Kodi. It was working perfectly, in the sense that whenever I wanted to switch on the Raspberry Pi, I could leave the HDMI cable of the extractor plugged in.

For the last few months though, every time I want to switch on the Pi, I first need to unplug the HDMI cable of the extractor (which is connected to the Pi) and connect directly the Pi to the TV, and then plug the extractor in between.

I initially thought it could be because of an update in Kodi. Then I thought it could be because the power supply was not powerful enough. So I bought an official one, but the problem remains.

Would you have any idea of what I could try to tackle this issue?

  • Have you also tried to increase signal to HDMI? While booting, hole shift, and select edit config. There is an option for that. – Unsigned_Arduino Oct 25 '18 at 22:28
0
+50

I'm not sure why it would have changed but have you tried forcing HDMI output on the pi?

It's described here: How do I force the Raspberry Pi to turn on HDMI?

Basically, edit /boot/config.txt/ with the lines:

hdmi_force_hotplug=1
hdmi_drive=2

Now reboot and it should work?

The first line forces hdmi output, second line should send audio to the hdmi.

0
  • Buy a no brand HDMI splitter with 1 input and 2 outputs.
  • Connect HDMI output of Pi to splitter input.
  • Connect splitter output A to TV as normal, then splitter output B to extractor.

This will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.