0

I'm using Raspberry Pi 3 and a 5" TFT LCD I got from Newegg. There is a large black space on the right side of the screen where nothing is being displayed. How can I get the Pi to use the full screen?

2

I'm assuming you are using Raspbian?

First things first, make sure you are powering the Pi with a decent 2A 5V power supply. Ensure the Pi has fully recognized the display by running:

dmesg | grep -i ft5406

If everything is good you will get this output:

[ 5.224267] rpi-ft5406 rpi_ft5406: Probing device
[ 5.225960] input: FT5406 memory based driver as /devices/virtual/input/input3

There's a possibility overscan might be enabled so going into raspi-config and disable it.

If you look in the config.txt file on the SD card you should find some lines of code that look like this:

#overscan_left=-20
#overscan_right=-20
#overscan_top=-20
#overscan_bottom=-20

It might be worth uncommenting the left or right line by removing the hashtag, so you would end up with this instead, for example:

overscan_left=-20
#overscan_right=-20
#overscan_top=-20
#overscan_bottom=-20

If you installed the OS using NOOBs check if these lines of code are present at the bottom of the config.txt file:

#NOOBS Auto-generated settings
overscan_left=24
overscan_right=24
overscan_top=16
overscan_bottom=16
disable_overscan=0

To prevent any of these lines of code from taking effect just add a # in front of the line of code. I would suggest commenting out all of them before you try anything else.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.