I had direct Ethernet connection without a router working in Ubuntu 16.04 for SSH as explained at: https://raspberrypi.stackexchange.com/a/53823/33424

But when I tested again 17.04, set "Shared to other computers", and select that connection, an error dialog appears:

Connection activation failed.

(0) Active connection could not be attached to the device

The only thread I could find was: https://askubuntu.com/questions/856007/failed-to-add-activate-connection but "All users may connect to this network" is already checked.

RPI 2 + Raspbian Jessie 2016-05-27 and 2017-04-10.

up vote 4 down vote accepted

To find the cause of this issue it is advisable to inspect the system logs, while the problem occurs.

To do so, open a console (maybe as root/sudo) then you can follow the logs like so: Generally journalctl -f and specifically for NetworkManager issues journalctl -f -u NetworkManager.

Now try to activate the connection and see what might hint you to the cause of error.

In my case I think I upgraded like you did (16.something to 17.04) and found dnsmasq missing, with one log line saying <error> ... (eno1) failed to start dnsmasq: Could not find "dnsmasq" binary. This was solved by installing the package dnsmasq. It is recommended to install dnsmasq-base (e.g. sudo apt-get install dnsmasq-base).

There is a bug report to pre-install dnsmasq-base by default on Ubuntu at: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1678606 since it breaks the network sharing GUI feature.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.