2

I have a Raspberry 2 Model B with raspbian jessie and I have realvnc-server installed. I've created a new user in raspbian and when I try to connect remotely via VNC viewer with the new user, I get an "access denied" message. I can only connect via VNC with the "pi" user.

I had a look to the config files in /etc/vnc/ but I could not find a directive in the server options related to this problem. Also tried converting my new user in a sudoer, but still got no acces.

Do you know if I need to tweak some config in the viewer instead?

I'm using a compatible vnc viewer as remarked in https://www.raspberrypi.org/documentation/remote-access/vnc/README.md.

4

Login as the pi user, right click the vnc system tray icon and select options, go to the users and permissions page and add your new user there.

By default it should allow users that are members of the sudo group (which includes the pi user by default)

  • I've succeeded to log in with my user using vnc, but when I type "whoami" in the terminal, I see "pi" instead of my user ? – rodrunner May 30 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.