I'm unable to enable VNC on raspberry pi 3, I've tried using preference > raspberry Pi configurations and through terminals raspi-config. It shows me that it has successfully enabled VNC, however if I go back to configurations it's back to disabled. Also I'm unable to connect with VNC viewer from my mac.

I've installed vnc server on my raspberry pi with:

sudo apt-get install realvnc-vnc-server

Is there a file somewhere where I can update this manually?

2 Answers 2


It turns out when installing real vnc server I left out -y what fixed everything was adding the below:

sudo apt-get install -y realvnc-vnc-server

and then rebooting

I found the answer here: https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=161341


The commands that get run when you enable VNC via either of these methods are as follows:

sudo systemctl enable vncserver-x11-serviced.service
sudo systemctl start vncserver-x11-serviced.service

So I would suggest running these from the terminal and seeing if you get any errors reported.

You can also run the following to see if the server is actually running:

sudo systemctl start vncserver-x11-serviced.service

You should also see the VNC icon in the system tray if the server is running.

Also, if you are using anything other than the RealVNC Viewer on your Mac, then you will need to change the Authentication setting in the VNC Server options to "VNC password" instead of the default "UNIX password", and set a separate password for VNC. I would recommend installing the RealVNC Viewer if you haven't already, since this supports UNIX password authentication, plus encrypted connections.

  • 1
    thanks Andrew for your help, it helped me on right path because now I knew that the Icons should show up. However what solved it was running sudo apt-get install -y realvnc-vnc-server I didn't include the -y and it wasn't working.
    – RobRalph
    Jun 11, 2017 at 16:51
  • I refered to this doc for more information. Oct 24, 2017 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.