2

I have tried using the on-board Wi-Fi as well as a USB Wi-Fi adapter on my Raspberry Pi 3 Model B.

I am using Ubuntu Mate 16.04. After putting in the Wi-Fi password, I see the Wi-Fi showing up as connected. In about 6 or so seconds, the authentication window pops up and wants me to enter the password again. It keeps on repeating.

I have tried setting up the Wi-Fi manually as follows:

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf network { ssid = "mySSID" psk = "my password" }

Please suggest a solution if you have solved this problem.

  • Your best bet for functioning software is to use what everyone else is using. Try rasbian instead. – Thorbjørn Ravn Andersen Jun 5 '17 at 16:52
3

For me, worked by restarting the service. Do this: sudo service NetworkManager restart

1

Ubuntu Mate uses NetworkManager which stores its configuration files in /etc/NetworkManager/system-connections

If you want to use MATE set it up in the normal manner via the GUI, rather than trying to fiddle with the rather complex NetworkManager files.

0

I use a similar method as on Raspbian.

I put the following to /etc/network/interfaces (I think this is the part you are missing):

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

And then I put the details to the /ect/wpa_supplicant/wpa_supplicant.conf:

country=GB

network={
    ssid="MyWifiNetwork"
    psk="myP4ssw0rd"
}

It works for me with Raspberry Pi 3 Model B and Ubuntu Mate 16.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.