0

I had two programs, one using DS18b20 sensors and the One-Wire and the other using SPI. On another pi, I had a program using the camera which had an error(still not sure what the error was) fixed by rpi-update. I wanted to run the three programs fro one pi so I used rpi-update and the two programs stopped working

My boot/config.txt file has

NOOBS Auto-generated Settings:

hdmi_force_hotplug=1
start_x=1
gpu_mem=144
dtparam=spi=on

dtoverlay=spi-bcm2708
dtoverlay=w1-gpio-pullup, gpiopin=17

But /sys/bus/w1/devices/ shows no temperature sensors but this instead

00-740000000000  00-f40000000000  w1_bus_master1

lsmod show

Module                  Size  Used by
binfmt_misc             7988  1 
bnep                   12051  2 
hci_uart               20020  1 
btbcm                   7916  1 hci_uart
bluetooth             365511  22 hci_uart,bnep,btbcm
brcmfmac              222874  0 
brcmutil                9092  1 brcmfmac
cfg80211              543027  1 brcmfmac
snd_bcm2835            24427  3 
rfkill                 20851  4 bluetooth,cfg80211
snd_pcm                98501  1 snd_bcm2835
snd_timer              23904  1 snd_pcm
snd                    70032  9 snd_timer,snd_bcm2835,snd_pcm
bcm2835_gpiomem         3940  0 
w1_gpio                 4818  0 
wire                   32619  1 w1_gpio
cn                      5889  1 wire
fixed                   3285  0 
uio_pdrv_genirq         3923  0 
uio                    10204  1 uio_pdrv_genirq
i2c_dev                 6913  0 
fuse                   99603  3 
ipv6                  408587  32  

/etc/modprobe.d/raspi-blacklist.conf doesn't exist

and /etc/modules only shows i2c-dev

I updated and upgraded the system as well. Would ideally not like to downgrade the rpi-update

sudo vcdbg log msg shows

001778.709: Failed to load overlay 'spi-bcm2708'
001800.541: Loaded overlay 'w1-gpio-pullup'
001800.557: dtparam:  gpiopin=17
001804.215: Unknown dtparam ' gpiopin' - ignored
2

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911

Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."
sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

  • Hi! Thanks so much! Had no idea about that. Noted for the future That seems to have fixed the SPI. But any idea about the 1-wire? Edited the question to include more about that bit. – Baba Jun 6 '17 at 0:38
  • Never mind! Seems like removing the spaces in the line "dtoverlay=w1-gpio-pullup, gpiopin=17" fixed it. Strange that it's been working for weeks with that. But thanks so much again! – Baba Jun 6 '17 at 0:56
  • many many thanks!!!! the space between w1-gpio-pullup, gpiopin=17 costed me many days, and motivation! now it works thx! – sepp Aug 10 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.