0

I cannot seem to get Lakka to output audio to the Speaker Jack.

Lakka sees two audio devices, but both look like the same thing, and neither gives me audio.

Lakka (community) Version: 2.0
Lakka:~ # aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=ALSA
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device
sysdefault:CARD=ALSA
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device

1

Use Putty to login to your Pie User = root Password = root

At the terminal cmd prompt type

nano /storage/.config/autostart.sh

This will create a startup file

Inside this file type in

amixer cset numid=3 1

Use ctrl+x to exit the file then Y to save the file.

Reboot and your sound should now be coming from your audio jack every time you startup Lakka

New contributor
Steve Griffith is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Much like how you do it for Rasbian, the command:

amixer cset numid=3 1

Will force the audio out the speaker jack.

According to the Lakka documentation we are somewhat limited to how we can enter console commands, with SSH being the easiest.
In Lakka:

Settings->Services->SSH
Information->Network Information (to get the IP Address)

On a connected PC: in Putty (or similar). Enter the ip address in the host text box. When prompted for username/pass enter root/root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.