I installed the Raspbian lite image to my SD card.

After that I installed PIXEL and VNC Server using these commands:

sudo apt-get install realvnc-vnc-server realvnc-vnc-viewer

sudo apt-get install --no-install-recommends raspberrypi-ui-mods gvfs lxterminal xserver-xorg-video-fbturbo

But when I connect, I see only black screen.

enter image description here

How can I fix this?

up vote 1 down vote accepted

You have discovered a "feature" of the Raspbian Lite OS. The way Raspbian Lite differs from Raspbian is it has no GUI, (Graphical User Interface).

So when you try to VNC into the Pi, you are going to get no GUI, as that is exactly what you would get if you connected the Pi to a monitor using HDMI.

However, I can confirm that using SSH will work normally. Also, if you do want to make use of VNC the normal Raspbian distribution will work and I believe it has VNC built-in and enabled by default.

Edit:

It is possible to install the packages required for a GUI interface, this page on the official Raspberry Pi Forum gives a really good explanation and comparison of the different GUI's.

I read tons of posts about this issue... and they all resulted in a RealVNC / x11VNC / Remoter black screen VNC connection on my Mac to my Raspberry Pi.

DISPMANX was the ulimate solution to VNC into the Raspberry Pi running Raspbian Lite.

Here is the summary:

1) BASIC SETUP - RESULTS IN BLACK SCREEN FOR VNC

SSH Enabled via Raspi-Config on Raspberry Pi Remoter for Mac (VNC + SSH/Terminal Access) SETUP: https://computers.tutsplus.com/tutorials/take-control-of-your-raspberry-pi-using-your-mac-pc-ipad-or-phone--mac-54603

2) TO ELIMINATE BLACK SCREEN FOR VNC

Setup DISPMANX, Desktop GUI for Raspbian Lite needs Additional Support SETUP: http://raspmer.blogspot.ca/2015/07/vnc-server-for-raspberry-pi-with.html

3) START DISPMANX VNC VIA RASPBERRY PI DESKTOP/GUI - NOT REMOTE SSH/TERMINAL sudo dispmanx_vncserver

4) CONNECT VIA REMOTER TO IP

MORE: Black screen using VNC with Raspbian Lite

SUCCESS

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.