0

I have installed Raspbian OS. I have configured my Pi's DHCP like this

static ip_address=10.1.1.1/8
static routers=10.1.1.1
static domain_name_servers=10.1.1.2

I have set 10.1.1.2 to be my Windows PC IP address. I tried to SSH using PuTTY/git bash it says "access denied".

On my Pi , in auth.log I see this

Jun  6 19:05:02 pi sshd[839]: error: Received disconnect from 10.1.1.2: 13: Unable to authenticate [preauth]
Jun  6 19:16:27 pi sshd[1134]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=10.1.1.2  user=pi
Jun  6 19:16:29 pi sshd[1134]: Failed password for pi from 10.1.1.2 port 50601 ssh2
  • 2
    the log does appear to mention a failed password...? – paj Jun 6 '17 at 19:38
  • Yes, but I have the same password , I used this password to log into pi – Sachin Setiya Jun 6 '17 at 19:49
  • can you ping the pi from your windoze pc, and are you sure ssh-server is installed and enabled on the pi? – paj Jun 6 '17 at 19:51
2

You have to enable SSH on your Raspberry Pi 3.

To enable it run this command raspi-config in the terminal, then go to the advanced menu and select enable SSH.

If you don't have a monitor and you still want to enable SSH on your Pi running Raspbian:

Create a blank file without any extension named as "ssh" Then place the file in the "boot" partition of your SD card

-1

Run: ssh -vvv

That will show all details. Also, on the Raspberry, check that sshd is running by using:

ps awx|grep sshd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.