0

I installed the POSBox image (I tried v14 and v15) on a Raspberry Pi 3, and everything worked great. Now I would like to use that RPi as a graphic POS, but when I type:

sudo apt-get install

I get

W: Unable to read /etc/apt/apt.conf.d/ - DirectoryExists (2: No such file or directory)  
E: Could not open lock file /var/lib/dpkg/lock - open (2: No such file or directory)    
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Screenshot of error

  • 2
    Probably not the cause of your problem but using sudo when you are logged in as root is redundant. Did you bother checking whether the paths it says cannot be accessed exist or not? – goldilocks Jun 7 '17 at 15:02
1

Maybe I missed something but I think sudo apt-get install, needs to know what to install. sudo apt-get install toilet for example.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.