0

When I do the same thing with my Windows desktop with PuTTY, everything's fine. However, my Ubuntu laptop can't seem to find it. It always replies with no route to host. I also tried it with a USB 3.0 to ethernet adapter, but the result hasn't changed.

I asked this question before. That reply solved half of the problem, but now, it won't connect at all.

  • Are you sure your Ubuntu laptop and the rpi are connected to the same physical network and they are configured with unique ip addresses on the same ip subnet? – paj Jun 8 '17 at 15:47
0

Have you tried this?: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=138631 ... at page 4 i found solution. Therefore my problem was little bit different i have SSH via ethernet but not via WiFi dongle. Still hope editing /etc/ssh/sshd_config...with the line "IPQoS cs0 cs0" helps you.

0

This works for me (Ubuntu 17.10).

  1. Find out the name of your Ethernet connection.

$ ifconfig

enp0s25: [...]

The name is enp0s25

  1. Change the IP address to the same subnet as the Raspberry. So if your Pi has the address 192.168.20.30 you might use

$ ifconfig enp0s25 192.168.20.31 netmask 255.255.255.0

  1. ssh
0

Turns out I have to set the wired connection settings to link-local in order to do it.

Can't believe it took me this long.

One thing to note: if you don't have a static IP, run an # arp-scan to the interface your Pi is connected to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.