1

I'm having a strange problem.

Every few days my Pi looses the connection to my Wi-Fi and only after I disconnect and connect the Pi to the power supply does the connection come back.

I saw in the /var/log/messages the lines:

Jun 11 11:18:06 MY_PI kernel: [    2.385881] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, e2:18:25:ad:b4:4a
Jun 11 11:18:06 MY_PI kernel: [    3.381314] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
Jun 11 11:18:06 MY_PI kernel: [    3.801944] NET: Registered protocol family 10
Jun 11 11:18:06 MY_PI kernel: [    4.496800] EXT4-fs (mmcblk0p2): re-mounted. Opts: errors=remount-ro
Jun 11 11:18:06 MY_PI kernel: [    5.100023] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
Jun 11 11:18:06 MY_PI kernel: [    5.131787] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
Jun 11 11:18:06 MY_PI kernel: [    5.352605] usbcore: registered new interface driver brcmfmac
Jun 11 11:18:06 MY_PI kernel: [    5.379316] brcmfmac_sdio mmc1:0001:1: firmware: direct-loading firmware brcm/brcmfmac43430-sdio.bin
Jun 11 11:18:06 MY_PI kernel: [    5.382946] brcmfmac_sdio mmc1:0001:1: firmware: direct-loading firmware brcm/brcmfmac43430-sdio.txt
Jun 11 11:18:06 MY_PI kernel: [    5.467877] random: nonblocking pool is initialized
Jun 11 11:18:06 MY_PI kernel: [    6.244507] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
Jun 11 11:18:06 MY_PI kernel: [    6.246223] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Jun 11 11:18:06 MY_PI kernel: [   67.775004] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jun 11 11:18:06 MY_PI kernel: [   67.776660] brcmfmac: power management disabled
Jun 11 11:18:09 MY_PI rsyslogd-2007: action 'action 17' suspended, next retry is Sun Jun 11 11:18:39 2017 [try http://www.rsyslog.com/e/2007 ]
Jun 11 11:18:09 MY_PI kernel: [   72.940734] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jun 11 11:18:09 MY_PI wpa_action: WPA_IFACE=wlan0 WPA_ACTION=CONNECTED
Jun 11 11:18:09 MY_PI wpa_action: WPA_ID=0 WPA_ID_STR= WPA_CTRL_DIR=/var/run/wpa_supplicant
Jun 11 11:18:09 MY_PI wpa_action: ifup wlan0=default
Jun 11 11:18:14 MY_PI wpa_action: creating sendsigs omission pidfile: /run/sendsigs.omit.d/wpasupplicant.wpa_supplicant.wlan0.pid
Jun 11 11:18:14 MY_PI wpa_action: bssid=f4:c2:6d:7f:4d:ff
Jun 11 11:18:14 MY_PI wpa_action: freq=2437
Jun 11 11:18:14 MY_PI wpa_action: ssid=MY_WIFI
Jun 11 11:18:14 MY_PI wpa_action: id=0
Jun 11 11:18:14 MY_PI wpa_action: mode=station
Jun 11 11:18:14 MY_PI wpa_action: pairwise_cipher=CCMP
Jun 11 11:18:14 MY_PI wpa_action: group_cipher=CCMP
Jun 11 11:18:14 MY_PI wpa_action: key_mgmt=WPA2-PSK
Jun 11 11:18:14 MY_PI wpa_action: wpa_state=COMPLETED
Jun 11 11:18:14 MY_PI wpa_action: ip_address=192.168.1.2
Jun 11 11:18:14 MY_PI wpa_action: p2p_device_address=b8:cc:ed:d0:c3:aa
Jun 11 11:18:14 MY_PI wpa_action: address=b8:cc:ed:d0:c3:aa
Jun 11 11:18:14 MY_PI wpa_action: uuid=58dedc32-65e0-5eb3-ae75-c0bed55ca4a1

Does anyone has an idea why this is happening?

(I do not think it's a power supply problem).

  • 1
    How have you ruled out power? Power issues are the most common cause of intermittent failures like this. – Steve Robillard Jun 11 '17 at 11:55
  • I am using 5V-3A 3000mA Power Adapter Supply... – Ahiel Jun 13 '17 at 13:54
  • That is what the label says, but not neccesarily what the board sees. – Steve Robillard Jun 13 '17 at 14:54
  • Do you have any suggestions for specific power supply? – Ahiel Jun 13 '17 at 15:01
1

It may be that wireless power management kicks in.

Try the following crontab entry (sudo crontab -e).

@reboot (sleep 30; /sbin/iwconfig wlan0 power off)&

  • I have tried it, and still, it happen again now... – Ahiel Jun 13 '17 at 12:54
  • That's unfortunate. I'm afraid I have nothing else to suggest. – joan Jun 13 '17 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.