0

Firstly, apologies for the long subject title, I'm lacking a better description for the issue that is presenting itself, and Linux experience.

The best way of describing what is happening is to look at the images attached, you will see in the 'Other' menu subgroup that there is a substantial amount of shortcuts to various things (programs/files?).

Screenshot "Other" sub-menu

This sub-menu contains just about every program on the Pi plus some... In lxde-pi-applications.menu file, located in ~/.config/menus/ everything appears to be in correct order as shown below:

Screenshot of lxde-pi-applications.menu file

So why is the 'Other' menu sub-group full of all this stuff, and more importantly, how to I remove it all from the 'Other' men sub-group (only)?

I also posted this on the RPi forums, but wanted to post here as well to enhance my chances of getting an answer and hopefully helping others who are experiencing the same problem.

  • Have you tried the Menu editor? – Milliways Jun 12 '17 at 6:54
  • Yes. The errant menu entries do not show up in the man menu editor, only what is show above in the screenshot of the applications menu file, which I have excluded from the menu. – Warrnambool Radar Jun 12 '17 at 15:00
1

I have solved the problem!

The instructions are a little complicated, so make sure you follow them exactly.

First of all, I have tested these instructions and they definitely work. Sorry about the faulty ones I accidentally posted before.

Second of all, the file that you have to edit is /etc/xdg/menus/lxde-pi-applications.menu, not /home/pi/.config/menus/lxde-pi-applications.menu


Open the file and scroll down to the section that looks like this (around line 137):

    <!-- Other -->
    <Menu>
        <Name>Other</Name>
        <Directory>lxde-other.directory</Directory>
        <OnlyUnallocated/>
        <Include>
            <And>
                <Not><Category>Core</Category></Not>
                <Not><Category>Settings</Category></Not>
                <Not><Category>Screensaver</Category></Not>
            </And>
        </Include>
        </Menu> <!-- End Other -->

Change it to look like this:

    <!-- Other -->
    <Menu>
        <Name>Other</Name>
        <Directory>lxde-other.directory</Directory>
        <OnlyUnallocated/>
        <Include>
            <And>
                <Not><Category>Core</Category></Not>
                <Not><Category>Settings</Category></Not>
                <Not><Category>Screensaver</Category></Not>
                <Not><Category>X-Debian</Category></Not>
                <Not><Category>X-Debian-Applications</Category></Not>
                <Not><Category>X-Debian-Applications-Accessibility</Category></Not>
                <Not><Category>X-Debian-Applications-Editors</Category></Not>
                <Not><Category>X-Debian-Applications-Education</Category></Not>
                <Not><Category>X-Debian-Applications-File-Management</Category></Not>
                <Not><Category>X-Debian-Applications-Graphics</Category></Not>
                <Not><Category>X-Debian-Applications-Network</Category></Not>
                <Not><Category>X-Debian-Applications-Network-Communication</Category></Not>
                <Not><Category>X-Debian-Applications-Network-Web-Browsing</Category></Not>
                <Not><Category>X-Debian-Applications-Programming</Category></Not>
                <Not><Category>X-Debian-Applications-Science</Category></Not>
                <Not><Category>X-Debian-Applications-Science-Mathematics</Category></Not>
                <Not><Category>X-Debian-Applications-Shells</Category></Not>
                <Not><Category>X-Debian-Applications-Sound</Category></Not>
                <Not><Category>X-Debian-Applications-System</Category></Not>
                <Not><Category>X-Debian-Applications-System-Administration</Category></Not>
                <Not><Category>X-Debian-Applications-System-Hardware</Category></Not>
                <Not><Category>X-Debian-Applications-System-Monitoring</Category></Not>
                <Not><Category>X-Debian-Applications-System-Package-Management</Category></Not>
                <Not><Category>X-Debian-Applications-Terminal-Emulators</Category></Not>
                <Not><Category>X-Debian-Applications-Video</Category></Not>
                <Not><Category>X-Debian-Applications-Viewers</Category></Not>
                <Not><Category>X-Debian-Education</Category></Not>
                <Not><Category>X-Debian-Games</Category></Not>
                <Not><Category>X-Debian-Games-Adventure</Category></Not>
                <Not><Category>X-Debian-Games-Toys</Category></Not>
                <Not><Category>X-Debian-Help</Category></Not>
                <Not><Category>X-Debian-Screen</Category></Not>
                <Not><Category>X-Debian-Screen-Locking</Category></Not>
                <Not><Category>X-Debian-Screen-Saving</Category></Not>
            </And>
        </Include>
        </Menu> <!-- End Other -->

A restart may be required for the changes to take effect.

This worked for me and should solve the problem.


Not the answer you're looking for? Browse other questions tagged or ask your own question.