1

I installed FreeBSD into Raspberry pi 3, but after downloading and extracting ports tree from portsnap. Now, I also installed pkg (ports-management) binary for binary installation. But, after installation of pkg i tried lots of others binary installation using pkg but it throws an error

[root@rpi3 /usr/ports/net]# pkg Shared object "libarchive.so.6" not found, required by "pkg" [root@rpi3 /usr/ports/net]# uname -a FreeBSD rpi3 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r318898M: Thu May 25 15:07:15 MDT 2017 [email protected]:/usr/home/brd/rpi3/crochet/work/obj/arm64.aarch64/usr/src/sys/GENERIC arm64 [root@rpi3 /usr/ports/net]#

Shared object "libarchive.so.6" not found, required by "pkg"

I tried updating or reinstalling it using pkg-static bootstrap -f but nothing happened. I also tried re-installation from ports tree,but again nothing happened.

I also followed this below link , but nothing works.

Shared object “libarchive.so.5” not found, required by “pkg”

2 Answers 2

2

Had the same issue so I added a symlink to libarchive.so to resolve.

ln -s /usr/lib/libarchive.so /usr/lib/libarchive.so.6

(now mind you I'm in no way a BSD expert so confirm the consequences of this and or best practice)

3
  • Thanks for your help :) . I searched a lot about configuring or installing any binary that will also load libarchive.so.7 library file , and i forgot about making a simple symlink to libarchive.so.6 :D
    – bsdboy
    Jun 14, 2017 at 14:34
  • Confirmed that this worked for me on Rpi 3.
    – fugitive
    Jun 16, 2017 at 15:37
  • Confirmed! Worked for me on Rpi3, raspbsd.
    – Drew
    Feb 10, 2018 at 21:00
1

Using pkg-static instead of pkg will work around this.

This happens because arm64 packages are built against an older userland where ino64 updates affect some system components.

1
  • Well , right now, issue was solved by above answer by @david and also thanks for your update on this, but i already used pkg-static so many times but nothing worked.
    – bsdboy
    Jul 11, 2017 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.