1

Question

How do I BANISH NTFS FOREVER from raspbmc?

Background

I don't know what's the problem between my raspbmc and my external hdd. All I know is that the ntfs partition of the external hdd keeps "removing" and "connecting succesfully" in an infinite loop. The ext4 partition (the one that matters) works just fine. The problem is that if this loop is not interrupted, the pi eventually crashes and I have to reset (unplug and replug the cord). Even if I sudo umount /media/ntfsshit through ssh, raspbmc remounts it again! Against my will!

I tried removing the ntfs-3g package (didn't work). Then I added a blacklist.conf file to /etc/modprobed.d and it didn't work. It was like this:

blacklist ntfs
# the above didn't solve the problem, so I added:
install ntfs /bin/false
# but didn't work either

I'm tearing my hair off of my head, and I keep looking at my hammer, then to the pi, then to my hammer, and the idea of smashing it seems more and more attractive.

Please, save a stranger's sanity. Thanks a bunch!

MORE DETAILS:

The pi is connected to a wall outlet through a cellphone charger and the two usb ports are used as follows:

lower port: 7-ports powered usb hub (with a wireless mouse and the hdd)

upper: DWA-131 wireless dongle

  • Smashing your pi!??! GASP!! :D Just kidding, I know what you meant. :) – RPiAwesomeness Sep 11 '13 at 18:58
0

Have you looked at this package?

ntfs-config - Enable/disable write support for any NTFS devices

But this one might be more what you are interested in

usbmount - automatically mount and unmount USB mass storage devices

| improve this answer | |
0

There is a solution over at the Unix Stackexchange, which might be applicable here. You need to create a new udev rules file, e.g. /etc/udev/rules.d/90-hide-partitions.rules and fill it with a rule matching your NTFS partition:

KERNEL=="sda2",ENV{UDISKS_PRESENTATION_HIDE}="1"

All of the above is taken from the linked solution. You need to adjust sda2 with the name of your NTFS partition.

| improve this answer | |
0

Nevermind, folks. The problem had not much to do with ntfs itself, but with the power delivered to the external hdd. The powered usb hub I was using delivered around 500 mA. I replaced it with a 3.8A usb hub, which is effectively 7 x 500mA + some extra juice for the hub itself, I suppose. The thing is that the usb specification requires each port to be able to deliver 500mA, so this new hub is able to deliver that amount (and more) of energy through each of its 7 ports.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.