0

I've been trying to set up my Raspberry Pi3 with a VPN on a Jessie Lite image. I've been successful with using the PiVPN installer to create a stable server, and client generator (OpenVPN based). My issue comes after importing the .ovpn file into the client and connecting to the VPN.

After I connect to the VPN, I am unable to access my network or any internet services even though I'm successfully connect to the VPN. If I'm acting as the VPN server, it is able to go out into the internet and the network, but when I'm a client logged into the VPN I cannot do any of that.

I checked online for fixes and I've seen post after post about fixing the DNS to google's or fixing the iptables, but none of those suggestions have worked. I feel like I'm at an stand still and need some guidance. Chances are, if you've seen any other post like this with fixes, I have already tried them.

I appreciate any help that you are willing to provide.

0

I was able to fix this issue. I was using a port triggering rule which was only allowing access to the pi, whenever it made a request. I changed this rule from port triggering to port forwarding, which allowed the pi and pi users to make request.

  • can you give more information about the resolution of the issue please? – silgon Dec 26 '18 at 18:21
  • The port triggering was causing inconsistency in the system causing the client connection to be unstable. By changing to a port forwarding solution the system stabilized and the client connection was able to pass through the VPN and reach out to the internet and onto the network. – msaptrta Jan 4 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.