1

For reference, this is the project I'm talking about here https://github.com/MichMich/MagicMirror

bash command being referenced:

bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)"

When I try to run the bash command to download and install MagicMirror, I get the error:

Note.js installation Done!
Cloning MagicMirror...
fatal: could not create work tree dir 'MagicMirror'.: Read-only file system

I tried to run the bash command again, but I got an error telling me that dpkg was interrupted and asked me to run another command, so I ran:

sudo dpkg --configure -a

and re-ran the bash command a third time, only to arrive at the error:

E: Sub-process /usr/bin/dpkg returned an error code (1).

Some additional information: I’m running the command as pi user.

I’m running Raspbian with PIXEL because when I download NOOBS to a micro SD, ‘Raspbian’ doesn’t show up as an option (even with Ethernet connected). I was assured by some people on Reddit that Raspbian with PIXEL was the same, just with a UI.

I’ve wiped and re-installed NOOBS at least four times on this micro SD card, taking about an hour each time, and all I want is a working mirror

Do I need to go about a different way of installing this software? I’m unfamiliar with Linux so any simplified version is appreciated.

  • Try running those commands as root sudo whatever command – sir_ian Jun 14 '17 at 23:46
  • That ought to make those commands work but won't fix whatever the underlying problem is. – sir_ian Jun 14 '17 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.