-1

I have recently acquired a Raspberry Pi 3 Model B. The audio doesn't work and having looked at other people's comments online I am not the only one having this problem.

I have tried the things that have been advised by other people, but because my knowledge of coding is limited I am not able to really give much info.

  • 1
    Is it just audio over HDMI or audio through the 3.5mm jack? What operating system are you using? It could be you need to change something in the settings relating to audio. Trying different combinations of HDMI cables and displays might also be worth a go. – Darth Vader Jun 15 '17 at 15:20
  • The 3.5mm works when I plug the headphones in. Using Debein, can't spell it and NOOBS. I have raspberian as well. Though i may be completly butchering the spellings of the words – Recrof Neeht Jun 15 '17 at 15:38
  • Please describe what you have done, what the result was, and how that differed from the result you expected. – Bex Jun 16 '17 at 7:45
  • Bex. The things that are described by Vader are the things in which need to be done. The only thing that seems to have been left out of what he/she was sugesting is that you must restart the Pi. – Recrof Neeht Jun 16 '17 at 18:00
2

Open a Terminal window and run:

sudo raspi-config

In raspi-config select Advanced Options and press the ENTER key select Audio and press ENTER. By default I think the option is Auto but you should try changing the option so it forces audio through HDMI then press ENTER to enable that mode. Exit raspi-config by pressing the right arrow followed by selecting Finish.

If that still does not work you will need to edit the config.txt file:

sudo nano /boot/config.txt

Then in the file set hdmi_drive=2, this means removing the # before hdmi_drive=2. This un-comments that piece of code and means that it will run. Then press CTRL+X to exit the file and press the Y key twice.

A final thing you could change in the config.txt file is un-commenting the lines:

hdmi_group=1 
hdmi_mode=4

After you have finished making any changes be sure to reboot the Pi so the changes take effect.

If the solutions above don't work then its a case of trying a new cable. You could also try reinstalling Raspbian. The display you are using might not have audio built in or the audio system its connected to might not be switched on.

Make sure you check all of the obvious stuff first.

  • apparently the first command doesn't exist. sudo rasp-config: command not found. – Recrof Neeht Jun 15 '17 at 18:18
  • Sorry that was a typo on my part, the command is sudo raspi-config – Darth Vader Jun 15 '17 at 18:22
  • ok, well. I'm looking at the second option and it seems a bit to complicated for someone of my skill set. – Recrof Neeht Jun 15 '17 at 18:27
  • As in you have made the changes I recommended in raspi-config and are trying the edit the config.txt file? – Darth Vader Jun 15 '17 at 18:34
  • yes. I think I see something. It's saying, "uncomment to force a HDMI mode rather than DVI. This can make audio work in DMT (computer monitor) modes" Is that what I need? – Recrof Neeht Jun 15 '17 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.