I'm using CUPS for my Samsung CLP-315. It works very well, but it is too slow. It normally takes five minutes or more to print a single page (from pdf).

When it's printing, gs is taking 100% of the CPU.

Is there a way to make the gs at the printing computer instead of on the pi? or even better, not using gs at all?

  • it seems we do have a cups tag :)
    – SteveIrwin
    Commented Apr 8, 2013 at 9:53

3 Answers 3


I am assuming you are using server side driver ie. have the CUPS use the Samsung driver.

You might be able to speed up the printing process by making the printer a RAW printer.DO this by selecting the Printer model as RAW when selecting the printer and installing the drivers on the computer.This will reduce the CPU load significantly.

However setting the printer as a RAW printer, you won't be able to print from inside the Raspberry pi.

Here is a nice tutorial which might be useful in setting this up.

Hope it helps.


I reduced the resolution to 150x150 dpi, performance is now ok (10-20 seconds per page), whereas with 600x600 dpi it took several minutes per page.

PS: RAW queue did not work in my network printer (a Lexmark X543) although it makes sense to offload the processing to the network printer.


I could solve the above problem in my case by setting my printer as a raw printer on the rpi. However, I needed a trick on my Linux Mint 17 client with CUPS v.1.7.2 to make it work. When I added the printer to my CUPS on the client, I had to give its URL with an option "compression=none" as follows: ipp://*my_rpi_IP_address*:631/printers/*my_printer_name_on_rpi*?compression=none Of course, the right printer driver had to be selected on the client as well. Interestingly, the above option was not necessary on a win7 client for the printer to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.