0

I set up JupyterHub on my rpi3 via ssh, and want to access it from another computer (not through ssh, but through <rpi3's ip address>:<port>)

My computer and my rpi3 are on the same subnet (192.168.1.14 and 192.168.1.20).

Using a second ssh session, I verified that the server is indeed running at 127.0.0.1:8081. But I'm unable to connect to it even within that session at 192.168.1.20:443.

Why and how to fix?

ssl pi description

The configuration is in the image.

0

If it is ip_tables, you can run these commands in order to fix the issue:

  1. sudo apt-get update
  2. sudo apt-get install ufw
  3. sudo ufw enable
  4. sudo ufw allow 443 (Where 443 is the port number to allow.)

There is documentation available for Ubuntu for this which is a similar process to the process for the Pi. This documentation is available at UFW - Uncomplicated Firewall.

EDIT: As this comment very rightly said, you must connect over HTTPS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.