0

I'm using a raspberry pi zero to record audio. I have a usb audio dongle plugged in to it for the microphone. However, when I record with it, the input is EXTREMELY staticy. It's pretty much unusable. I tried plugging in the microphone into my computer and it works fine. I also tried a different microphone with a different USB input device and that was still unusable. What should I do?

  • Can you please explain the noise "staticy" ? Do you mean low frequency hum or literally wideband noisy static ? – Matt Jun 18 '17 at 1:26
2

first try this: arecord -f s16_LE -r 8000 -d 10 test8k.wav

and record "This is 10 seconds of 8 kilo-hertz 16 bit mono"

then play it back:

aplay test8k.wav

Much better?

========== If audio output is too soft - in command prompt can do: 
> alsamixer 
          s (select card)
          downarrow to “0 bcm2835 ALSA” 
          8      (4=default loudness, 8=100%, 9=125%)
          Escape (press Esc) then make setting default:    sudo alsactl store 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.