1

I have this Raspberry Pi 3 installed with Windows IoT Creators Update 10.15063 and a 7" Touchscreen Display.

First, when booting, the Windows logo and loading appears, but then its a blank screen and the Pi boots again. After that blank again.

It was working before Windows update. And if I'm using a Pi connected to another monitor display via HDMI it works.

  • If a Windows update is what caused the problem, what is the issue with rolling back to a slightly older version that worked? – Darth Vader Jun 18 '17 at 9:57
  • Yeah, I want to downgrade it, but afaik there's no option in the Windows Device Portal and from the IoT Core Dashboard, if I want to make another bootdrive again it will be Windows 10 15063 version. Anyway, it was updated to 15063 because of autoupdate or something, I never really wanted to update it... – Naufal B Jun 18 '17 at 12:33
  • Sounds like an unintenional bug. The only thing is to report it and hope somebody had time to check it out or somebody can provide a workaround. The autoupdate feature is nice.. if it doesnt break anything. It must be something to do with the constant work they doing on the graphics drivers. It is all for the best but yea... see if anybody else has the same problem by posting this on the - try this - social.msdn.microsoft.com/Forums/vstudio/en-US/… – Piotr Kula Jul 3 '17 at 7:55
0

Post updating to 15063.251, I faced similar issue. I connected the HDMI cable to my desktop monitor and it worked. It was taking too long with the two tooth wheels running and configuring. Post all of that it restarted. Then I connected the 7 inch display (it was still blank).

I connected to raspberry via IoT Dashboard in desktop, right clicked on the device and opened the "Open Device Portal". In that browser window, under Devices menu, Microsoft Basic Display Driver, click "Generic Non-PnP Monitor". The Raspberry was connected to internet at that time. It updated the driver for monitor and immediately prompted for restart. However, the driver name still the same but post restart, the 7 inch display works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.