1

This is a cross between Linux and Android because apparently this occurred:

I flashed a Raspbian image with the dd command to my SD card and it won't run even though I followed the steps. My Pi or other computers can't read the SD card but its there, yet inaccessible.

My rooted Android device can read it but it says its corrupted, disabling the mount procedure. On the Android device I see it in /dev/block as a Linux core filesystem and nothing else. Now I tried some ways to delete the files on the SD card but it kept deleting the virtual SD card. I tried formatting it yet with no success due to not being able to find the main root of the SD card.

Any suggestions?

  • stream of conciseness may work for Joyce, but I suggest you try normal English. – Milliways Jun 20 '17 at 3:22
2

There a number of things that could be going wrong here. The first is the SD card is bad and that's why its corrupted or you might not have properly imaged the SD card.

Its not entirely clear what OS you are using but here are the steps if you have a windows computer. If you are using Linux a similar process applies:

First you are going to need to format the SD card, for Windows a piece software called MiniTool Partition Wizard exists. This allows you to see the different partitions on the SD card. Delete any partitions on the SD card and create one primary active partition the size of the SD card. Then in File Explorer right click on the SD card select format and format it to device defaults. Now your SD card is good to go for the installation.

Then go to the official download page for Raspbian.

Click the Download ZIP button, the ZIP file will start to download.

Once the download has completed you will need to unzip the 2017-04-10-raspbian-jessie.zip folder. Inside the unzipped folder you will find a Disc Image File called 2017-04-10-raspbian-jessie.

This file is what gets written to your SD card. to write the Disc Image File to your SD card is going to require a program like Win32 Disk Imager. Once you have it installed, open it and you will see a window like this:

enter image description here

Click the little folder button and go to the file location of the un-zipped Raspbian Disc Image file and select the file. You will also need an SD card connected to your computer and the location of that can be set under the Device drop down menu.

Once you are happy that you have the Disc Image File and correct drive letter for the SD card selected you can press the write button. It will take a few minutes for Raspbian to be written to the SD card. Once a message pops up saying the write was successful you can safely remove the SD card from your computer.

The SD card is now ready to be used in a Raspberry Pi. A slightly easier method of installation is to use NOOBS, which can be downloaded here. Once you have downloaded the ZIP file it will need to be unzipped. Once unzipped the files in the unzipped folder need to be copied to the SD card. And from there the SD card can be used in a Pi.

If after following these steps you are still encountering problems try using a different SD card. You also need to ensure you are powering the Pi adequately, be sure to use a power supply that can reliably provide 2A at 5V.

  • But the problem is: Where is it if it is detected but not showing up? – Hidden Jun 20 '17 at 14:30
  • What do you mean by not showing up? If its connected to a computer running something like Windows or Linux does it appear under drives? Does the SD card show up in Device Manager? – Darth Vader Jun 20 '17 at 14:35
  • Do we really know that the card is corrupted? Android (or his particular flavor) may just not be capable of reading a card with multiple partitions. – Jacobm001 Jun 20 '17 at 17:31
  • That's certainly true, but given the Pi doesn't want to boot, it does point to an SD card issue. Especially since he mentioned the card wasn't recognized on any of his computers. My questions above where trying to clarify if certain partitions of the card weren't showing up or the SD card just wasn't being recognized at all as a device. – Darth Vader Jun 20 '17 at 17:35
  • Just now i used my 32 gig sd card and formatted it to ext4 filesystem. the system must not know what to do with it so it cant recognize it. i run a third party software that uses all the main tools from raspbian. and my android tablet is a jellybean(not the food). is there a program that finds it? – Hidden Jul 13 '17 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.