My R-PI has been working fine for the past 5 days in a row with the official Soft-float Debian "wheezy", it was hard powered off by removing the plug from the wall, now the boot stops at the screen after the colored splash, the screen is completely black with the red berry logo on the top left corner, I see a cursor for 2/3 seconds and then nothing happens for at least 2 hours (no messages, kernel is not panic-ing, nothing is happening, red light is on, green is off).

I installed a bunch of software since last reboot:

  • java & scala
  • apache
  • mysql
  • php
  • the no-ip.org package

I tried to boot with only the screen connected (no eth, no usb devices), but still same result, I'm not even sure this is hardware related or software related, any debug suggestions?

  • The first thing to check is to try if it's not card content problem. Backup your whole SD card, write new firmware onto it (or just use another card if you have one) and check if it's working. If it is, copy all the files from this fresh card's /boot/ partition to some temporary place, recover the old card content and then try overriding files on /boot/ partition with those from temporary folder. It's possible that only kernel or firmware files (which are on /boot/ partition). Apr 9, 2013 at 6:14
  • Thanks, I've nothing valuable on that SD so I'll just go for a fresh re-install. Apr 9, 2013 at 10:39
  • DON'T JUST PULL THE PLUG. raspberrypi.stackexchange.com/questions/381/…
    – goldilocks
    Apr 9, 2013 at 13:55
  • I think I found the issue pastebin.com/yGDx5TxM I'll buy a new SD card :( Apr 10, 2013 at 21:20
  • @ArjunaDelToso Could you make the solution as a answer for the sake of others having the same problem!Thanks.
    – SteveIrwin
    Apr 14, 2013 at 20:36

3 Answers 3


The problem I described in the question was caused by the SD card being somehow damaged, I bought a new card, re-installed, now everything is working fine!


What I discovered is that you need to unplug the Raspberry Pi for about 10 minutes before loading the same or another SD card. If I switch cards to use a different OS-setup and doing this to soon I only get a splashscreen. After 10 minutes everything works fine again.

  • 1
    Can you explain why this might happen?
    – Impulss
    Oct 27, 2013 at 22:20

Mine did the samething, I had put an older version of NOOBS on card to try and install Arch Linux.

The solution was to reformat the card following the NOOBS instruction video, and put the latest version of NOOBS on the card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.