2

I just made my first raspberry pi web server. I am running it from my home. I currently don't have a domain name for it, but I do have my router port forwarding my pi. The page runs fine when I'm at home, but as soon as I'm on a different network I start getting issues. I have been able to view the web page once at a different location (my guess it was cached). When I try to connect to my web page using Chrome I get this error.

"The browser you are using may have difficulty receiving images and video. If you experience any issues viewing this page, we suggest using Internet Explorer, Mozilla Firefox, or Apple Safari"

When I tried to use Safari, it keep asking me for login in credentials and then would not authenticate.

Is my problem not having a domain name? Or are my web page request causing to much traffic for the pi?

My pages are pretty simple and I try to get files smaller. So I really don't know what would cause this. Any suggestions to fix this problem, or advice would be great, thanks.

  • 1
    When connecting remotely, which IP address are you using? The local address of the RPi, or your actual home IP address? – Jacobm001 Jun 21 '17 at 15:12
  • Are you hosting a webpage you made, or something else? – Jacobm001 Jun 21 '17 at 15:13
  • I'm remotely connecting through with my home IP address. It works fine using ssh to get into my pi. Im also just hosting a basic webpage I made. All front-end stuff. – Bryan Mcneil Jun 21 '17 at 20:51
0

Based on some similar issues I've found online, it sounds like you own a D-Link router and it's configured to accept remote administration over port 80. If you disable that, or move it to another port, that should solve your issue.

  • Thanks for the help. Looks like changing the port helped. Just for others to know. You have to change the ports on apache too. Under port.conf and 000-default.conf. Here is an article I used. apache – Bryan Mcneil Jun 21 '17 at 21:14
0

Try running this in the terminal:

For the official tutorial from remote3.it see the bottom of this post!

Check the OS Version

First, you will need to determine which version of the OS is installed on your Pi. Run:

cat /etc/os-release

You should see this line:

VERSION="8 (jessie)"

This shows you are using raspberry pi Jessie! Or stretch will work also!
If you are using the Wheezy version of Raspbian, or to support other ARM boards using Debian (such as BeagleBone Black and Wandboard), please follow the installation directions here.

Install the weavedconnectd package

First, get the latest repositories:

sudo apt-get update

Next, download the remot3.it weavedconnectd package:

sudo apt-get install weavedconnectd

Run weavedinstaller to configure remot3.it service attachments

Next, run

sudo weavedinstaller

You should then see a list of options, press 2, then press enter Then follow the on-screen instructions to enter your e-mail. Remote3.it will send you an e-mail with a verification code that you must enter by selecting 3 from this menu. After that, your account is active and you can add devices and services. In this case, website!

Now that you have created an account, select option 1, then log in. Note that the password is not displayed as you type. Next, as there are no services yet installed, you will be asked to enter the Device Name. Valid characters include numbers, letters, space, underscore, and dash. After you have entered your name, Press 1 to attach remot3.it to one of your services. Select the type of service you are connecting to, in this case a web server so press 2 then hit enter! You will then be asked if the default port 80 is the port to use press y, if you aren't on port 80 then put n, and then the correct port! You can repeat this with as many ports as needed! Select a name for the service, for example Pi-Web After you enter the name, a few more seconds passes while it is registered to your account. Next, you will be returned to the Installed remot3.it Services menu. Now your attachment to the web service is shown. Press 4 to exit or register a new service or port with the corresponding Keys! Navigate to https://remote3.it and sign in! You will see your devices there and can go to the link provided in your remote3.it account to access server! This link changes regularly! You don't need to port forward your router though!

Remote3.it Official Tutorial Here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.