0

My Raspberry pi 3 is connected on Wifi. My purpose is to access the raspbian via wifi to be able to edit the code. My attempt to access with the Ethernet is successful, however when I try to do the same via Wifi it seems to not work.

Link already tested but without luck: https://github.com/OpenLabTools/OpenLabTools/wiki/SSH-on-Raspberry-Pi-with-Ethernet-and-or-WiFi

Any suggestion ?

  • 1
    what command are you using to connect to the wifi? What is the IP of the WiFi connection on the Pi? – Steve Robillard Jun 21 '17 at 20:53
  • I only connected the Pi3 to the monitor and then tried to connect it to the wifi. At this point, the connection to the wifi always fails (tried with different wifi networks). – Malloc Jun 21 '17 at 23:38
  • It would help if you shared what type of error you are getting. Sounds like you're not using the correct passphrase for the wireless network. It's pretty straight forward in the GUI. – stevieb Jun 22 '17 at 0:17
  • 1
    It would also help to know exactly how you tried to connect to the WiFi, and what protocol you are using. No SSH connection via WiFI will work until you can connect. So your issue is not with SSH not working but with the WiFi config. Please also edit your question and add the output of the ifconfig command. – Steve Robillard Jun 22 '17 at 0:23
  • I think I was mistaken; I read this as the OP can't connect to wifi, not connect to the Pi over wifi – stevieb Jun 22 '17 at 0:25
0

SSH 1) Enabled ssh link by console: $sudo nano /etc/ssh/sshd_config In #Authentication Section Edit PermitRootLogin yes

Restart SSH $sudo /etc/init.d/ssh restart OR

$sudo service ssh restart

2)By Raspi-config

3)Configuration on startx (Graphics Mode)

ENABLED WIRELESS Edit /etc/dhcpcd.conf for static address and /etc/wpa_supplicant/wpa_supplicant.conf

sudo nano /etc/dhcpcd.conf

In last line: interface eth0 static ip_address=192.168.1.110/24 static routers=192.168.1.1 static domain_name_servers=8.8.8.8

interface wlan0 static ip_address=192.168.1.10/24 static routers=192.168.1.1 static domain_name_servers=8.8.8.8

/etc/wpa_supplicant/wpa_supplicant.conf

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

network={ ssid="your_ssid" psk="your_ssid_password" }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.