10

I just bought raspberry pi 3 with Rapbian Jessi with Pixel and I have a Lenovo laptop with Ubuntu 14.04 64 bit on it.

I want to remote connect to it from my laptop. I enabled the VNC server on Raspberry Pi and I tried to connect to it from either Remmina 0.9.99.1, Remote Desktop Viewer, or even Gtk VNC Viewer. In Remmina it gives me the following error:

Unknown authentication scheme from VNC server: 13, 5, 6, 130, 192

I failed to make this work, although I can connect smoothly using SSH. Any ideas how can I make it work as it looks it should be a straight forward thing.

5

later I found out another solution to make it work for Remmina 0.9.99.1. You can change the security authentication for the VNC server to be VNC Password instead of Unix password and create an admin user credentials so you can use it in the remote connection as the following:

On VNC Server side on Raspberry Pi 3

Go to the options on the VNC Server on Raspberry Pi 3 and you should have the sudo credentials when you started VNC server

Change the security authentication to VNC Password as shown belowenter image description here

Finally you need to add a user to use it to connect. In my case I created an administrator user (default username was admin)

On Remmina side on Ubnutu

You will create a new connection with the given IP address of the Raspberry Pi on your local network (you should be able to know it using ifconfig) and using the admin user credentials created on VNC server as the following: enter image description here

Please note that It worked with me while encryption was off, as it made some problems mentioned in other posts. I will try to see if it will work with encrypted on or no.

  • Given that this requires turning off encryption I would consider this a non-starter from a security perspective. – Steve Robillard Jun 22 '17 at 13:59
  • non-starter unless you are using an ssh (encrypted) tunnel and restrict vnc either with a firewall or a network mask of allowed addresses (or both) – Scott Wood Oct 26 '17 at 15:40
  • I always use SSH tunnel and using -localhost (for tightvncserver) and ip mask for realvnc-vnc-server, so no one except me from tunnel can enter. Plus a little 8 lenght password, of course. Same for vps than for rpi. Security is a must, always. – erm3nda Mar 30 '18 at 19:20
2

The simplest solution is to install RealVNC Viewer. You can download it from here, and it is available for Linux, MacOS and Windows. The issue is with the encryption schemes used by different VNC servers.

  • Or better still use use a non-proprietrary VNC server such as tightvncserver – Milliways Jun 23 '17 at 0:43
  • fine only if you don't need an ssh tunnel – Scott Wood Oct 26 '17 at 15:40
1

I found out that with the current authentication on VNC using linux authentication, the only way to make it work is to use the RealVNC viewer settings of VNC viewer on Ubuntu 14.04

all what you need is to download the binary file (or GZ file and un-compress it and then make the file executable and so you can run it.

0

I read tons of posts about this issue... and they all resulted in connection from my Mac via Remoter to a black screen on the Raspberry Pi.

DISPMANX was the ulimate solution to VNC into the Raspberry Pi running Raspbian Lite.

Here is the summary:

BASIC SETUP - RESULTS IN BLACK SCREEN FOR VNC

SSH Enabled via Raspi-Config on Raspberry Pi Remoter for Mac (VNC + SSH/Terminal Access) SETUP: https://computers.tutsplus.com/tutorials/take-control-of-your-raspberry-pi-using-your-mac-pc-ipad-or-phone--mac-54603

FINAL SETUP - TO ELIMINATE BLACK SCREEN FOR VNC

Desktop GUI for Raspbian Lite needs Additional Setup i.e. DISPMANX SETUP: http://raspmer.blogspot.ca/2015/07/vnc-server-for-raspberry-pi-with.html

START VNC VIA GUI - NOT REMOTE SSH sudo dispmanx_vncserver

CONNECT VIA REMOTER TO IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.