I just bought raspberry pi 3 with Rapbian Jessi with Pixel and I have a Lenovo laptop with Ubuntu 14.04 64 bit on it.

I want to remote connect to it from my laptop. I enabled the VNC server on Raspberry Pi and I tried to connect to it from either Remmina, Remote Desktop Viewer, or even Gtk VNC Viewer. In Remmina it gives me the following error:

Unknown authentication scheme from VNC server: 13, 5, 6, 130, 192

I failed to make this work, although I can connect smoothly using SSH. Any ideas how can I make it work as it looks it should be a straight forward thing.


8 Answers 8


later I found out another solution to make it work for Remmina You can change the security authentication for the VNC server to be VNC Password instead of Unix password and create an admin user credentials so you can use it in the remote connection as the following:

On VNC Server side on Raspberry Pi 3

Go to the options on the VNC Server on Raspberry Pi 3 and you should have the sudo credentials when you started VNC server

Change the security authentication to VNC Password as shown belowenter image description here

Finally you need to add a user to use it to connect. In my case I created an administrator user (default username was admin)

On Remmina side on Ubnutu

You will create a new connection with the given IP address of the Raspberry Pi on your local network (you should be able to know it using ifconfig) and using the admin user credentials created on VNC server as the following: enter image description here

Please note that It worked with me while encryption was off, as it made some problems mentioned in other posts. I will try to see if it will work with encrypted on or no.

  • 1
    Given that this requires turning off encryption I would consider this a non-starter from a security perspective. Commented Jun 22, 2017 at 13:59
  • 1
    non-starter unless you are using an ssh (encrypted) tunnel and restrict vnc either with a firewall or a network mask of allowed addresses (or both)
    – Scott Wood
    Commented Oct 26, 2017 at 15:40
  • I always use SSH tunnel and using -localhost (for tightvncserver) and ip mask for realvnc-vnc-server, so no one except me from tunnel can enter. Plus a little 8 lenght password, of course. Same for vps than for rpi. Security is a must, always.
    – m3nda
    Commented Mar 30, 2018 at 19:20
  • How do you do this from the terminal? (through SSH tunnel)
    – Elie G.
    Commented Dec 19, 2019 at 1:36
  • Doesn't seem to work. Newly installed Pi 2 Raspbian.
    – NoBugs
    Commented Mar 7, 2020 at 4:28

I've just encountered the issue too.

As an alternative to aibrahim's method if you are doing it remotely via ssh, here's my steps to VNC to display :0.

  1. Setup password using sudo vncpasswd -service
  2. Add the following lines to /root/.vnc/config.d/vncserver-x11 as described in RealVNC: Support legacy viewers
  3. Start vncserver using command sudo vncserver-x11-serviced

This method allows me to login using Ubuntu's Remmina VNC client.

  • 1
    This worked perfectly in 2020 on a Pi 4 with latest rapsberry pi os
    – user230910
    Commented Aug 8, 2020 at 0:53
  • 5
    The service can be restarted with sudo systemctl restart vncserver-x11-serviced.service Commented Dec 13, 2020 at 22:39
  • Worked perfectly on pi 3b / raspbian. Commented Mar 3, 2021 at 12:37
  • Worked perfectly for me: Ubuntu 20.04 -> Raspberry Pi 4 Model B Rev 1.2 (Raspbian GNU/Linux 10 (buster))
    – Glushiator
    Commented Nov 4, 2021 at 19:09
  • UPDATE: 2023-04-02 Ubuntu 22.04 LTS RealVNC server on the RPi now has a checkbox to allow "legacy" logins. When this is checked, then Remmina may log in. This checkbox is found when setting the VNC Password for login of the "Standard user" Commented Apr 2, 2023 at 20:51

The simplest solution is to install RealVNC Viewer. You can download it from here, and it is available for Linux, MacOS and Windows. The issue is with the encryption schemes used by different VNC servers.

  • 2
    Or better still use use a non-proprietrary VNC server such as tightvncserver
    – Milliways
    Commented Jun 23, 2017 at 0:43
  • fine only if you don't need an ssh tunnel
    – Scott Wood
    Commented Oct 26, 2017 at 15:40

The main problem is that the Raspberri Pi runs RealVnc as server. Lots of answers suggest to connect using RealVncViewer. But RealVnc is not really free, it has a free version, and uses special encryption schemes. Probably good ones, but this makes it harder to use other VNC clients.

Steps to find out about this:

  • aptitude search vnc
  • look for installed packages with i in the first column
  • on my PI it showed realvnc

The obvious solution, and I tried this with success, is to remove the RealVNC server from the Pi, and to switch to a 'regular' VNC server like x11vnc. Steps:

  • Go to Preferences, Pi Configuration, Interfaces, and disable VNC
  • In a terminal: sudo aptitude remove realvnc-vnc-server
  • sudo aptitude install x11vnc # or another vnc server
  • start the VNC server with: x11vnc -display :0 (see also man x11vnc)

On your ubuntu pc, you may now connect to the PI with e.g. Remmina

Todo: start the VNC server on the PI in the background

  • I don't have aptitude on my Raspberry Pi 2. Just saying.
    – bomben
    Commented Jan 4, 2021 at 17:54
  • @Ben The real un*x guru of course uses apt because (s)he knows all command line options by heart. But for the rest of us, aptitude is just a little easier to use. You will have to install it with something like apt-get install aptitude. It is available on Ubuntu, Raspbian, etc.
    – Roland
    Commented Jan 13, 2021 at 10:04

I found out that with the current authentication on VNC using linux authentication, the only way to make it work is to use the RealVNC viewer settings of VNC viewer on Ubuntu 14.04

all what you need is to download the binary file (or GZ file and un-compress it and then make the file executable and so you can run it.


I had the same exact problem, after searching through I found that problem was related to authentication and following line helped me to resolve the issue. I forgot which Stack Exchange I found the answer from.

Here are the steps that I took:

  1. Connect to your Raspberry Pi through ssh command.

    ssh pi@your raspberry ip

    Then enter your password to your Raspberry Pi.

  2. Start your vncserver on your Raspberry Pi with the following command

    vncserver -Authentication VncAuth :1
  3. Go to your Remmina:

    1. Set your protocol to VNC
    2. Enter the IP address from your raspberry pi new desktop this should be in the last line after entering the code in step 2
  4. Put your username and password for Raspberry Pi

  5. If you set up different password for your VNC server you need to add to the prompt.

After this I was able to remote log-in to my Raspberry Pi.

I found bits and pieces of the info on different exchange and had to put it together.


I read tons of posts about this issue... and they all resulted in connection from my Mac via Remoter to a black screen on the Raspberry Pi.

DISPMANX was the ulimate solution to VNC into the Raspberry Pi running Raspbian Lite.

Here is the summary:


SSH Enabled via Raspi-Config on Raspberry Pi Remoter for Mac (VNC + SSH/Terminal Access) SETUP: https://computers.tutsplus.com/tutorials/take-control-of-your-raspberry-pi-using-your-mac-pc-ipad-or-phone--mac-54603


Desktop GUI for Raspbian Lite needs Additional Setup i.e. DISPMANX SETUP: http://raspmer.blogspot.ca/2015/07/vnc-server-for-raspberry-pi-with.html

START VNC VIA GUI - NOT REMOTE SSH sudo dispmanx_vncserver



I had a similar problem when trying to connect to Raspbian Buster and the instructions at the link below solved my problem without having to install a new VNC server.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.