I have this problem during the last weeks so I'm going to detail it everyting I can. I'm sorry if there is unnecesary info here.

A few weeks ago I changed my home network. Before changes, I had a simple conexion to my PC and RaspberryPi via PLC from my router. At this point everything work perfectly.

Now I have this network at home:

  • My old router (NETGEAR CG3110D) have wifi disabled and is working only as neutral modem (my conexion arrives as coaxial cable and that was the unique option I had).
  • My new router (Archer C7 v2), has the Internet input connected to the output of my old router. It has the dualwifi enabled too.
  • My PC and my Raspberry Pi 2 B are connected via Enternet cable direcly to my new router.

Now my network info is

Old router network

  • Old router , (DHCP enabled)
  • New router

New router network

  • New router , (DHCP enabled and with enough addresses)
  • PC
  • Chromecast
  • Printer
  • RaspberryPi

My RaspberryPi connect well when my pc is disconnected. So if I connect my RaspberryPi first than my PC it works fine. I tried adding a default gateway to raspbian and connecting manually (no dhcp), and it dont work.

I crimped again a few times some cables and I bought a connection tester. I can say that all network cables are working fine. RaspberryPi and routers software are all up to date.

  • 1
    Did you config your RPi to use a fixed IP adress or did you use the default setting, IP adress given by a DHCP ? – Technico.top Jun 22 '17 at 15:47
  • 2
    How is the network configured on the RPi and the router? My thought is that this is more related to your router than the RPi. – Jacobm001 Jun 22 '17 at 17:48
  • 1
    Are you running DHCP servers on both routers? At any event this is not a Pi question, and you haven't provided enough information for anyone to solve your problem. – Milliways Jun 23 '17 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.