Hello everyone I have the Raspberry pi 3 with the raspbian system. I have installed the Firefox ESR browser and icewaesel -> Firefox ESR. Every time I open it I slow down a lot the raspberry and I can not open two windows in a row without being blocked for minutes. How can I make it go faster or thinner?

  • perform this test. run the two firefox windows and post screenshot of top command in terminal, output of df command to see fs usage, and output of free -mh command to show memory usage.
    – crasic
    Commented Aug 1, 2017 at 20:41
  • Also, for good measure, perform a system update sudo apt-get update && sudo apt-get upgrade -y to clean up any outdated packages
    – crasic
    Commented Aug 1, 2017 at 20:43

4 Answers 4


Web browsing on a Raspberry Pi is slow, but it's certainly not normal to wait for minutes for a new window to open. I suggest you make a fresh install with no extra software except for Firefox (no addons!), and retry.

If opening a new window (except the first one) still takes more than a few seconds, I would try getting a different SD card.

  • I am literally using a brand new install so I don't think it has anything to do with that. Commented Mar 12, 2023 at 1:53

I have been having this problem for as long as I got my Rpi and I was very upset with it.

It is slow because it uses SD card for the main hard drive. I suspected this for a long time but I could not get my head around it since it would be slow has soon as I would access any, any website.

Firefox and Chrome will cache website hence will write on a slow device cached information and will put on hold Firefox will writing to the "SLOW" device.

Just deactivate cache in preferences and history too... anything that writes to the disk, or use a faster device SD card or USB key mounted for your personnal directory.

It worked for me.

Good luck.



You can use Chromium Browser which is the default browser of Latest Raspbian.

If you haven't update your os with Pixel you can upgrade it.

more details about pixel you can find from here:


I had the same problem with my RPi 3+ with a SSD as maindrive. The system is up to date (update&upgrade)

I used "top" to find out that swap was running out of free space evertime I used firefox with some tabs open wich contained very active webcontent (java) After augmentation of swapspace to 500MB (/etc/dphys-swapfile , standard is 100) at least raspian doesn't freeze anymore and after execution I can close windows to make system faster again.

I hope this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.