0

I used etcher to load the image of the raspbian lite onto a micro sd card. When I try to boot up my raspberry pi with a previously used sd card it works. Then I take out that SD card and try the new one with the new image on it and power it up and it shows the rainbow screen then a raspberry Pi logo as if it is about to show a linux system powering up, but no text appears and then the rainbow screen comes back. This keeps happening repeatedly.

I turn it off and then try the old sd card again and it works, it powers up as it should. Anyone know what the problem is? I guess the sd card/sd card reader?

  • 1
    It's likely that this card is borked. Try to reflash it, however it might be broken beyond repair. To be sure, you did use an image for the Pi 2 and not a Pi 3, right? – Ghanima Jun 23 '17 at 19:50
0

I never used etcher. Whenever I prime a SD card I use the dd Linux command. Windows guys use win32diskimager.

Anyhow: The etcher doc states it's checking the cloned images. If that's true then it seems the image you use is somehow broken. On the raspbian download page the sha1 is listed. Please use sha1sum to verify the sha1 of the downloaded zip file matches to the published sha1 and download the image again.

  • I checked the published sha1 with the downloaded zip and they are identical. Still I think I should download again? I am downloading from here and I have tried it on multiple computers – user3494047 Jun 23 '17 at 20:37
  • No. If the sha1 is identical the image is OK. It sounds edger is not able to detect a broken SD card. I suggest to try it again with another SD card. – framp Jun 23 '17 at 20:51
  • well i tested it with a working sd card. I had an sd card that worked. Deleted all of the content (formatted it) then used etcher to put on a new image and then the problem happened again with the previously working sd card. Maybe it is my sd card reader (I am using a sd card reader to read the micro sd card) – user3494047 Jun 23 '17 at 20:56
  • I tried a different image and it worked (the picses)! But now now keyboard works :( – user3494047 Jun 23 '17 at 21:11
0

Fault with the image flashed to the SD card or the SD card is bad.

Format the SD (using SD Formatter) and try again,

Check the SD is the size it is supposed to be using F3 in Linux to test maximum write size before errors.

Check the integrity of the downloaded ISO/IMG file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.