0

I am attempting to use OpenCV on my Raspberry Pi 3 running Raspbian Jessie. After installing OpenCV I connected my Raspberry Pi camera 1.3 to the CSI port but the camera's red LED did not light up. Running a sample code gave this error:

mmal: Camera is not enabled in this build. Try running "sudo raspi-config" and ensure that "camera" has been enabled

So, as instructed, I went to the raspi-config menu but the camera option was not there!:

Screen shot of my raspi-config tool menu

Thinking that I may have plugged the camera cable the wrong way I tried flipping it, but this didn't work either. Looking this problem up in forums I found that for some people updating can fix it, so I ran the commands:

sudo apt-get update
sudo apt-get updrade

Afterwards I updated the rasp-config tool but this didn't work either. Desperate at this point I connected my camera to the DSI port of the RPI and found that the red LED lights up but my RPI would not detected anyways.

To me this boils down to two possibilities:

  1. My RPI's CSI port is brocken

If so, how could I use the DSI port with my camera instead?

  1. The CSI port is disabled

Is this even a possibility, how do I enabled it?

I will appreciate any feed back on this problem.

2

The camera option is the first choice in the Interfacing Options submenu

Camera Option

  • Thank you Very Much! I also had to increase the GPU memory from 64 to 128 MB for this option to appear. – Norrin Rad Jun 24 '17 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.