7

Ubuntu 16.04 LTS fully upgraded on computer Raspbian Jessie Lite fully upgraded on Rpi 3

I can SSH no problem into the raspberry, configured it from raspi-config to enable vnc at boot.

I then tried to connect to it via tightvncviewer and got the following error:

Connected to RFB server, using protocol version 3.3 No configured security type is supported by 3.3 VNC Viewer

Using VNCviewer on android it connects but only a black screen shows.

I tried to manually launch vnc server form ssh but still no luck.

What should the next step to fix this be?

  • 1
    "configured it from raspi-config" i.e. RealVNC which is a non-standard proprietary implementation, then "tried to connect to it via tightvncviewer" which is incompatible. – Milliways Jun 29 '17 at 10:45
7

You have 2 options

  • Install tightvncserver on the Pi, or
  • Install RealVNCviewer on your computer.
  • ... where tightvncserver (or x11vnc or ...) is in Raspbian, and RealVNCviewer is NOT in the ubuntu distro. 3rd option, as mentioned in another post, is to disable encryption . . . – Roland Sep 8 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.