1

I have an earlier Pi model circa 2012, with apache2,php5,mysql-client,mysql-server and phpmyadmin installed. I have an xfinity router (Comcast Cisco DPC3939) the gateway IP is 10.0.0.1. My Pi has a private address of 10.0.0.14 which I have set to reserved in my router settings. I have purchased a domain through google and have set up dynamic DNS with their api. I run the script and it returns an IPv6 address. I am also able to see the splash page of my website on domains.google.com. In my router settings I have enabled port forwarding on port 80. So my entry looks like something like...

Service type - TCP Server IP address - 10.0.0.14 Server IPv6 address - (matches my google ddns) start port - 80 end port - 80

After this the site is still only accessible at http://10.0.0.14 inside my LAN. I can't get to it by hostname outside of my network or even within my LAN. Am i missing something? I've tried to research this but all answers state that after forwarding the port I should be good to go.

EDIT: I can reach my site by using my public IP address : 80 outside of my LAN

EDIT: On my laptop when inside my LAN I am getting a connection timed out error, on my galaxy I am getting a server DNS can not be reached error. Also using a network IP scan tool on my phone I can see port 80 is open on my Pi... it says HTTP/1.1 200 OK And on my router when I scan port 80 I see it is open but I get a HTTP/1.0 400 Bad Request Content-Type text/html message.

Also tried forwarding port 8080 instead of 80 and then editing the two apache.conf files but still no good.

1

For anybody out there that used the Google API to set up dynamic DNS... You have to use the www. prefix when accessing the site or it won't work. Appreciate this forum and the chance to think things out loud helped lol.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.