1

I'm using Tim Schwartz's Raspberry Pi Video Looper to turn my Pi 3 Model B into a simple video player. It works flawlessly connected to my Samsung HDTV over HDMI as well as my older Apple Cinema Display with an HDMI to DVI adapter.

However, when I connect the Pi to my brand new BenQ W1090 projector, the video doesn't work right. The Raspbian loading sequence is displayed as normal, but after the startvideo.sh script runs, the video cuts in and out, alternating between video and black screen.

I've tried two different high quality HDMI cables and tried turning on config_hdmi_boost in config.txt (variables 4 to 11). I'm using the official Raspberry Pi power adapter (5.1 V, 2.5 A).

What could be wrong? Here's a link to startvideo.sh on GitHub.

Edit: Still doesn't work after updating omxplayer to the latest stable build on the Pi.

Edit 2: I've updated Raspbian. I've maxed out the gpu_mem in config.txt. My projector is compatible with 24 Hz video at 1080p (the video file is 23.976 fps).

Strangely: When I boot the Pi while attached to my Apple Cinema Display, then I unplug it and plug it into my projector, it works! According to the projector, the signal is 1920x1200 at 60 Hz. There are no problems whatsoever with blank screen. Is there a way to force the Pi to output 60 Hz instead of the file's native 23.976 fps format?

1

My solution is to re-export the MP4 video file using a frame rate of 24 fps instead of 23.976 fps. It now works with the projector. It seems absurd though that it's necessary to re-encode the video.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.