1

When I connect my Raspberry Pi to my cable modem, via Ethernet cable, it won't connect to the internet. The LAN light on the modem turns red when I connect to my Raspberry Pi. When I run ifconfig, I get a ip address for eth0.

The Ethernet cable is new, as is the modem (they came in the same package). The modem is not a modem/router combo.

I'm trying to setup my Raspberry Pi as router.

  • Can you give us the IP adress you get for eth0, and the modem model ? – Technico.top Jul 2 '17 at 2:36
  • Inet address: 169.254.227.13. – user3273814 Jul 2 '17 at 2:55
  • Model of cable modem is Zoom 5345. – user3273814 Jul 2 '17 at 2:55
1

Computers use 169.254.x.x addresses when they have a physical link to a router / modem, but they can't receive an IP address. (See here for more information about Automatic Private IP Addressing).

Things to try:

  • Restart your modem
  • Force a new IP - dhclient -r eth0
  • Restart your Raspberry Pi
  • Check the Ethernet cable works on other machines
  • Try using a different Ethernet cable
  • Restarting the modem while the Ethernet was plugged into the Raspberry Pi worked! – user3273814 Jul 5 '17 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.