1

The default version of bluez in Raspbian-Jesse is 5.23, which allows bluetooth low energy (BLE) devices to pair and even connect but does not respond to them thereafter! To solve this, one has to install an updated version of bluez. Earlier, I successfully followed this link, which gives the steps to upgrade to bluez-5.37. Bluetooth devices worked after enabling the experimental flag, restarting the bluetooth adapter, and a reboot.

When I tried doing the same thing on another installation of Raspbian now, the system behaves as if it has the old bluez version running. Indeed, I get the perplexing results given below

bluetoothd --version
5.23
bluetoothctl --version
5.37

Is this normal? It looks like inspite of the upgrade, the old bluez version is being actually used -- but I don't know, I'm guessing. How do I remedy this? If you are suggesting removing bluez-5.23, please tell me how to do that. I tried uninstalling bluez from pi, but that removes pi-bluetooth as well. What should I remove and what should I keep, for the BLE devices to work? And how?

1

I had also posted this answer on the Raspberry Pi Forum, and I followed through all the suggestions that people came up with. My problem got solved, but I think it is instructive to go through the discussion and read through to the end:

https://www.raspberrypi.org/forums/viewtopic.php?t=187486

The key point is that after upgrading bluez and adding whatever BLE device you want to add, you have to completely shut down the Pi instead of a simple reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.