I have been trying to stream live webcam footage from my PS3 eye toy (connected to RPI through USB).

I downloaded VLC and ran:

 vlc 4l2:///dev/video0

But I keep running into the error

VLC is unable to open the MRL 'v4l2:///dev/video0'

I even tried video1 but still got the same error

Any ideas?


2 Answers 2


Your user doesn't have permissions to open /dev/video because that dev file is owned by root user and video group. You need to add your user to the video group.

usermod -aG video ${USER}

The a is important as otherwise ${USER} will be removed from all other groups the user is already in (see man usermod). This includes sudo if ${USER} is pi.

Added group memberships aren't effective until the user next logs in.

  • 2
    Should be usermod -aG as If the user is currently a member of a group which is not listed, the user will be removed from the group. This behaviour can be changed via the -a option, which appends the user to the current supplementary group list.
    – crasic
    Commented Oct 4, 2017 at 22:32

As per this answer from the archlinux forums, it seems that vlc may require the zvbi package to be able to open v4l2 devices. Indeed, installing it solved the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.