I just got my Raspberry Pi 3 Model B today and after installing the OS image onto the microSD card along with the blank ssh file in the boot directory, I turned on my Pi and the OS seemed to be loaded successfully and showed up on my router (it was connected to my router since I was doing headless configuration). But when I tried to connect to the Pi using PuTTY, it says Network Error: Connection refused. How do I solve the problem? The SSH was enabled as prescribed by placing a blank ssh file so how do I solve this?

  • "the blank ssh file in the boot directory" -- please explain, where exactly was the "boot directory" – techraf Jul 4 '17 at 12:48
  • @techraf it is where the os files were located. – Nikhil Raghavendra Jul 4 '17 at 12:52
  • 1
    And you think anyone will help you, when you yourself don't care? – techraf Jul 4 '17 at 12:53
  • @techraf ok, let me explain this, once i downloded the img file from the website, i created a blank ssh file and copied it into the zip file. then used etcher and flashed it onto the sd card. – Nikhil Raghavendra Jul 4 '17 at 12:56
  • "copied into the zip file"? This makes no sense. – techraf Jul 4 '17 at 12:58

First of all I am new to Raspberry Pi 3 but I can successfuly connect to my Pi by using Putty. Secondly, I did not use any "blank ssh file" at all. All you have to do to connect via Putty is:

  1. Write "ifconfig" to the terminal in Raspberry Pi.

  2. There has to be eth0 section on top where you can see inet addr:"IP "address of your raspberry".

  3. Open up the Putty.
  4. Select "SSH".

  5. Enter your IP Adress. And click open.

  6. Terminal will open and it will ask "login as:". I assume you have not changed anything about your sudo, so it must be "pi". Write "pi" and enter.

  7. Now it will ask you your password. Again I assume you have not changed anything and it is "raspberry". Tap enter and I hope you successfully connected to your raspberry.
| improve this answer | |
  • How do you connect to the Pi before you get SSH enabled? This doesn't answer OP's question. – user42000 Jul 5 '17 at 15:39
  • I actually did nothing about enabling ssh in my Raspberry Pi and just did the steps above. That is why I didn't understand what does s/he mean by blank ssh file. Here is where I learned it . Remotely Connect from Windows with Putty SSH Telnet Client – Avio Jul 5 '17 at 16:49
  • Exactly, you have to enable it before you can use it headless, that's what the OP is asking about. – user42000 Jul 5 '17 at 19:42
  • I think it was ON by default on my raspberry. However, I might as well fail to answer the question. – Avio Jul 5 '17 at 20:48
  • It used to be turned on by default, they changed a while back to be off by default for security reasons. – user42000 Jul 5 '17 at 21:41

Ok so I have finally figured out how to enable SSH on Raspberry Pi 3 Model B and I have written a blog post on it.

There are too many images and bullet points which I need to show here in order to tell people how to solve this problem so please refer to this blog post (I am not advertising my blog!)

Here is the link: https://nikhilraghava.wordpress.com/2017/07/05/setting-up-the-raspberry-pi-on-headless-mode/

| improve this answer | |
  • This is a link-only answer which should be improved to be up to the site's standards. – Dmitry Grigoryev Jul 6 '17 at 8:03
  • Edit your answer for some points, and while you're at it, a few suggestions: 1. You can copy a working wpa_supplicant.conf to the /boot directory on your microSD card and raspbian will copy it and use it to enable bringing up wireless in a headless configuration, 2. You can locate the RPi as raspberrypi.local without knowing the IP address (assuming you didn't rename it at this point.) – bobstro Jul 6 '17 at 14:00

You can fix this problem by enabling ssh connection in raspberry pi 3. First you want connect raspberry pi 3 into monitor via HDMI port. Then you can connect raspberry pi 3 into wifi network to get internet connection. After that you should install openssh server.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.