1

I have my Pi's on a NetGear router which is itself connected to another Firewall and then to my DSL modem/router connection. Except for this issues all is working FINE.

I have 4 Pi's on the Netgear, 3 Wheezy OS's and one Jessie. The Jessie is the issue and is a new build with latest updates. I have added port 9000 to the /etc/ssh/sshd_config file. From the Netgear network I can access all of my Pi's via each ones unique port number, as well as port 22.

From the Firewall network, the DSL modem/router network and the Internet I can get, via the correct port numbers, to each of the Pi, except the new Jessie build.

Is there something I'm missing here? Something new in Jessie?

Thanks...RDK

  • Have you enabled SSH? Jessie (the correct spelling BTW) requires specifically enabling SSH. What error message do you get? What do you mean by added port 9000? Are you rnning SSH on a nonstandard port? – Steve Robillard Jul 5 '17 at 6:31
  • SSH is enabled as I can get to that Pi via Putty when on the Netgear network. When trying to access from outside the Netgear network, the Putty connection times out. I have set up the Pi to listen on both port 22 and port 9000, which works. From outside the Netgear network it does not respond to either port. – RDK Jul 5 '17 at 7:21
  • 1
    Can you do a traceroute and run putty with the -v verbose flag – Steve Robillard Jul 5 '17 at 7:24
  • I'm running on Windows 10. Tried tracert from the firewall network to the WAN port for the Netgear router. It times out since the Netgear router is blocking all traffic unless specified by a specific port. There does not seem to be a port option for tracert. When I run putty with the -v option from the firewall network, it just times out. – RDK Jul 5 '17 at 9:07
  • I know the putty request is getting to the Netgear router as it shows up in the log: "[LAN access from remote] from 192.168.xx.11:58075 to 192.168.yy.163:9000, Wednesday, Jul 05,2017 10:47:19 ". 192.168.xx.11 is the address of my Windows PC on the firewall network and 192.168.yy.163 is the Pi's address on the Netgear network – RDK Jul 5 '17 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.