1

I ran 'yum update' on my Raspberry Pi3 running Centos7, and now it will not boot. Both LED's are solid (no flashing) and it does not get past the 'Rainbow Screen'.

The following packages were installed: raspberrypi2-kernel to version 4.9.35-v7.1.el7

also updated were: raspberrypi2-firmaware and raspberrypi2-kernel-firmware to 4.9.35-v7-1.el7.

Does anyone know what may have gone wrong and how I may be able to resolve this? For example, can I just replace files on the /boot partition in order to get this working?

I have already attempted adding boot_delay=1 to config.txt in the boot partition.

0

It works on my Raspberry Pi3 after replacing the '/boot' contents with the contents of https://buildlogs.centos.org/centos/7/isos/armhfp/CentOS-Userland-7-armv7hl-Minimal-1611-test-RaspberryPi2.img.xz (so you might need the 3 version)

  • Before halting the system or with the file system mounted somewhere, change /etc/selinux/config SELINUX=enforcing
  • now might replace /boot
  • (re)move kernel7.img
  • rename the generic kernel, e.g. kernel-4.4.33-v7.1.el7.img or later, to kernel7.img

The same might work with newer kernels: http://mirror.centos.org/altarch/7/kernel/armhfp/kernel-generic/Packages/ - edit cmdline.txt and add enforcing=1

Later I added EPEL. Then I discoverd another update will install kernel 4.9.35 and 'python-psutil', than the kernel is updated and things work as promised in the documentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.