1

I'm going crazy trying to connect to my Pi through PuTTY. I know I have SSH enabled, I checked the ports, used ifconfig and put in every single IP address I saw in there, used hostname -I, and they all either say Connection timed out or Permission denied. All I want is to eventually be able to run a headless Pi but that's not looking so great right now.

5
  • How did you enable SSH? What OS and distro are you using? Are you using noobs? what is the output of: sudo service ssh status? Jul 6, 2017 at 19:31
  • I enabled SSH thru raspi-config. Using Windows 10, using NOOBS, and the output is: ' ssh.service - OpenBSD Secure Shell server Loaded: loaded (/lib/systemd/system/ssh.service; enabled) Active: active (running) since Thu 2017-07-06 12:01:28 PDT; 46min ago Main PID: 532 (sshd) CGroup: /system.slice/ssh.service └─532 /usr/sbin/sshd -D Jul 06 12:01:28 raspberrypi systemd[1]: Started OpenBSD Secure Shell server. Jul 06 12:01:28 raspberrypi sshd[532]: Server listening on 0.0.0.0 port 22. Jul 06 12:01:28 raspberrypi sshd[532]: Server listening on :: port 22.'
    – NeonCop
    Jul 6, 2017 at 19:50
  • Are you absolutely positive you are using the correct IP and port
    – Joe
    Jul 6, 2017 at 21:46
  • Yes, I just tried hostname -I, sudo service ssh status to make sure the port was fine, and I was given the timeout error. I can't figure it out for the life of me.
    – NeonCop
    Jul 6, 2017 at 21:58
  • Are you trying with IP address 192.168.xxx.xxx? It is better to use a network IP scanner to get correct IP address.
    – Arun
    Jul 7, 2017 at 10:40

2 Answers 2

1

Try to remove configuration and reconfigure the ssh solution here.

$ sudo rm /etc/ssh/ssh_host_* && sudo dpkg-reconfigure openssh-server

Many similar problem found on Noobs, and this one seems to have verified answer: SSH time out and connection abort

3
  • darn, that didn't work. I'm still getting the timeout error, even though I know I have the right port and IP address. Any other tips?
    – NeonCop
    Jul 6, 2017 at 22:57
  • You are on the one setting up samba on university network, right? Try isolated environment I suggested under your samba question.
    – Sean Lee
    Jul 6, 2017 at 23:01
  • Alright, sounds good, thank you very much for your help :)
    – NeonCop
    Jul 6, 2017 at 23:11
0

I avoid most of my former problems by just using win32diskimager to install the normal raspbian jessie distro instead of noobs. It is really simple to do, and there isn't any real difference between the two in my opinion.

3
  • Noobs gives you easy access to the config.txt
    – user67191
    Jul 7, 2017 at 2:06
  • It's the main reason that I use noobs instead of using the image
    – user67191
    Jul 7, 2017 at 2:06
  • eh, I have no reason to change the config.text file. I would try what I suggested though, if you can't rectify the situation. I'm sure you could probably find an easy way to get to the config.text file on the normal OS installation.
    – PiGuy88
    Jul 7, 2017 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.